First problem encountered with Symfony 2

Just solved my first problem with symfony 2. It was complaining about sqlite3 module or something…
http://symfony-hribo.blogspot.com/2011/01/you-need-to-enable-either-sqlite-or.html
will now restart apache to see how is it going?…

Right from the get go I also had to edit the php.ini @ /etc/php5/cgi
and also just to remember my short_open_tag by default were set to On on that same php.ini file
Symfony2 told me to change that to Off

Later on I also went ahead and installed the APC PHP caching system, easily searching on the ubuntu installer software
and I went ahead also for the intl module for php5 that was requiring…

so far all good until I click and get this:

Fatal error: Class ‘Symfony\Bundle\FrameworkBundle\FrameworkBundle’ not found in /home/cordoval/sites/Symfony/app/AppKernel.php on line 11

All of a sudden I noticed after cat README.txt that I have missed running the vendors.sh scripts and then noticed that I had not installed git! nothing that a sudo apt-get install git could not solve…

then again I ran into a weird thing, I had to run /bin/vendors.sh outside of the folder bin then did that but then got a problem with

sensio\Bundle\FrameworkExtraBundle\SensioFrameworkExtraBundle’ not found in /home/cordoval/sites/Symfony/app/AppKernel.php on line 18

So now it is a problem with the FrameworkExtraBundle

Scratched everything and did:

git clone git://github.com/symfony/symfony-standard.git .

now running vendors.sh again…

there are more scripts to be run on the README.md and now I found that symlinks is an option…

got it, it was just a singular, meaning no s at the end of symlinks

Ended the day by finishing the quick tutorial.

Leave a Reply

Your email address will not be published. Required fields are marked *